PPTP-Client и доменное имя вместо IP в connect-to

Обсуждение ОС и пр.
Аватара пользователя
DeN_238
Сообщения: 287
Зарегистрирован: 19 фев 2012, 16:42
Откуда: Тольятти

PPTP-Client и доменное имя вместо IP в connect-to

Сообщение DeN_238 » 04 апр 2012, 20:51

Сабж. Возможно ли? У моего провайдера под доменным именем скрывается пул адресов. Если указывать конкретный адрес, то в случае падения явно указанного сервера, без вмешательства в работу роутера не обойтись.
2011UAS-2HnD-IN | v. 6.37.1 | FW 3.33
mAP 2n | v. 6.36.3 | FW 3.24
iSupport
Сообщения: 2439
Зарегистрирован: 06 фев 2011, 20:44

Re: PPTP-Client и доменное имя вместо IP в connect-to

Сообщение iSupport » 05 апр 2012, 00:26

Роутер, если ему указать домен вместо айпишника - переведет его в ИП и будет с ним работать

Вопрос можно решить скриптом, который случайным образом будет подсовывать ИП из списка в подключение
Граждане, сколько раз просил =) чем понятнее и точнее сформулирован вопрос - тем понятнее и точнее будет на него ответ.
Я просматриваю ВСЕ темы форума и стараюсь помочь в каждой из них
Поэтому, НА ЛС отвечаю в последнюю очередь
sontrava
Сообщения: 66
Зарегистрирован: 26 июл 2011, 17:19

Re: PPTP-Client и доменное имя вместо IP в connect-to

Сообщение sontrava » 05 апр 2012, 14:04

# Define User Variables
:global dnshost "DNS имя нашего сервера"
:global pptpiface "имя нашего PPTP интерфейса"

:if ([interface pptp-client get $pptpiface running] = false) do={
/ip dns cache flush
:local currentip [:resolve $dnshost]
/interface pptp-client set [/interface pptp-client find name="$pptpiface"] connect-to=$currentip
:log info "PPTP_CHG_IP: IP changed new $currentip"
}
Аватара пользователя
DeN_238
Сообщения: 287
Зарегистрирован: 19 фев 2012, 16:42
Откуда: Тольятти

Re: PPTP-Client и доменное имя вместо IP в connect-to

Сообщение DeN_238 » 05 апр 2012, 19:00

Спасибо
2011UAS-2HnD-IN | v. 6.37.1 | FW 3.33
mAP 2n | v. 6.36.3 | FW 3.24
Аватара пользователя
Dragon_Knight
Модератор
Сообщения: 1190
Зарегистрирован: 26 мар 2012, 18:21
Откуда: МО, Мытищи
Контактная информация:

Re: PPTP-Client и доменное имя вместо IP в connect-to

Сообщение Dragon_Knight » 16 май 2012, 19:03

Скрипт стал актуален, спасибо, но возник вопрос: Создал новый скрипт, вставил туда этот код, а что дальше :?

Помощь в настройке оборудования MikroTik, Мытищи, Москва.
Дома: [RouterBOARD CCR1009-8G-1S-1S+] + [RouterBOARD cAP 2n] + [RouterBOARD Groove A-2Hn-32] + [D-Link ANT24-0800];
Работа 1: [RouterBOARD RB493G] + [MikroTik R52H] + [MikroTik CA493] + [D-Link ANT24-0800] + [RouterBOARD SXT G-2HnD];
Работа 2: [RouterBOARD RB2011UiAS-IN];
Резерв: [RouterBOARD RB450G];
podarok66
Модератор
Сообщения: 2861
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

Re: PPTP-Client и доменное имя вместо IP в connect-to

Сообщение podarok66 » 16 май 2012, 20:45

Ну, видимо, в шедулер воткнуть, с периодом исполнения там скажем раз в 5 минут. Пусть проверяет. Если соединения нет, он сменит айпишник, если есть, то не станет ничего делать...
Я не ошибаюсь?
Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
212deniska212
Сообщения: 1
Зарегистрирован: 03 июл 2012, 13:08

Re: PPTP-Client и доменное имя вместо IP в connect-to

Сообщение 212deniska212 » 03 июл 2012, 13:15

podarok66 писал(а):Ну, видимо, в шедулер воткнуть, с периодом исполнения там скажем раз в 5 минут. Пусть проверяет. Если соединения нет, он сменит айпишник, если есть, то не станет ничего делать...
Я не ошибаюсь?

хотел бы тоже услышать ответ на этот вопрос!?
sontrava
Сообщения: 66
Зарегистрирован: 26 июл 2011, 17:19

Re: PPTP-Client и доменное имя вместо IP в connect-to

Сообщение sontrava » 03 июл 2012, 15:43

Все просто.
Скрипт бросаем в шедулер.
Ставим период запуска 5-10 мин.

Он проверяет, если коннекта нет,
то по новой ресолвит IP из DNS
и делает по этому IP коннект

Вернуться в «MikroTik RouterOS»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей