Web-proxy и авторизация в Webfig

Обсуждение ОС и пр.
podarok66
Модератор
Сообщения: 2859
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

Web-proxy и авторизация в Webfig

Сообщение podarok66 » 27 фев 2012, 15:59

Настроил прокси по мануалу отсюда

/ip proxy
set enabled: yes
set src-address: 0.0.0.0
set port: 8080
set parent-proxy: 0.0.0.0:0
set cache-administrator: "webmaster"
set max-client-connections: 1000
set max-server-connections: 1000
set max-object-size: 512KiB
set max-fresh-time: 3d

Теперь, сделать его прозрачным в firewall

/ip firewall nat
add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=8080

Далее

/ip firewall filter
add chain=input in-interface=ether1 src-address=0.0.0.0/0 protocol=tcp dst-port=8080 action=drop

Теперь все, что нужно могу заблокировать, но и зайти с машин, топающих через проксю, я через Webfig не могу. Пишет, что неверный логин-пароль. Только через Winbox по МАС-адресу.
Не подскажите рецептик, как мне настроить авторизацию, чтобы можно было войти независимо от того, через прокси сервер я захожу или напрямую.
Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
iSupport
Сообщения: 2439
Зарегистрирован: 06 фев 2011, 20:44

Re: Web-proxy и авторизация в Webfig

Сообщение iSupport » 27 фев 2012, 16:15

сделайте так, чтобы локальный IP не *проксировался*
Граждане, сколько раз просил =) чем понятнее и точнее сформулирован вопрос - тем понятнее и точнее будет на него ответ.
Я просматриваю ВСЕ темы форума и стараюсь помочь в каждой из них
Поэтому, НА ЛС отвечаю в последнюю очередь
podarok66
Модератор
Сообщения: 2859
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

Re: Web-proxy и авторизация в Webfig

Сообщение podarok66 » 27 фев 2012, 19:40

iSupport писал(а):сделайте так, чтобы локальный IP не *проксировался*

О! Спасибо! А ларчик открывался просто. Действительно, зачем мне перенаправлять запросы на роутер? Правило в NAT немного изменил.
/ip firewall nat add chain=dstnat protocol=tcp dst-address=!192.168.100.1 dst-port=80 action=redirect to-ports=8080
Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...

Вернуться в «MikroTik RouterOS»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей