PPPoE BRAS

Тут размещаем отчеты о готовых работающих решениях на оборудовании Mikrotik
Lord3D
Сообщения: 49
Зарегистрирован: 04 окт 2012, 12:39

PPPoE BRAS

Сообщение Lord3D » 28 фев 2015, 20:14

Провайдерский PPPoE BRAS для нескольких посёлков на базе 1100AHx2.

 Конфиг

Код: Выделить всё

# feb/28/2015 13:15:32 by RouterOS 6.27
# software id = WDY1-FT2R
#
/interface ethernet
set [ find default-name=ether2 ] mac-address=AA:11:00:00:00:55
/interface pppoe-server
add name=pppoe-in1 service="" user=""
/interface vlan
add interface=ether2 l2mtu=1594 name=ether2.31 vlan-id=31
add interface=ether2 l2mtu=1594 name=ether2.32 vlan-id=32
add interface=ether2 l2mtu=1594 name=ether2.40 vlan-id=40
add interface=ether2 l2mtu=1594 name=ether2.41 vlan-id=41
add interface=ether2 l2mtu=1594 name=ether2.42 vlan-id=42
add interface=ether2 l2mtu=1594 name=ether2.44 vlan-id=44
add interface=ether2 l2mtu=1594 name=ether2.46 vlan-id=46
add interface=ether2 l2mtu=1594 name=ether2.500 vlan-id=500
/port
set 0 name=serial0
set 1 name=serial1
/ppp profile
set 0 dns-server=8.8.4.4,8.8.8.8 local-address=192.168.255.1 use-encryption=no
/routing ospf instance
set [ find default=yes ] name=ip redistribute-connected=as-type-1 redistribute-static=as-type-1 router-id=<A.B.C.D>
/interface pppoe-server server
add authentication=mschap2 disabled=no interface=ether2.40 max-mru=1480 max-mtu=1480 mrru=1600
add authentication=mschap2 disabled=no interface=ether2.41 max-mru=1480 max-mtu=1480 mrru=1600
add authentication=mschap2 disabled=no interface=ether2.42 max-mru=1480 max-mtu=1480 mrru=1600
add authentication=mschap2 disabled=no interface=ether2.44 max-mru=1480 max-mtu=1480 mrru=1600
add authentication=mschap2 disabled=no interface=ether2.46 max-mru=1480 max-mtu=1480 mrru=1600
add authentication=mschap2 disabled=no interface=ether2.31 max-mru=1480 max-mtu=1480 mrru=1600
add authentication=mschap2 disabled=no interface=ether2.32 max-mru=1480 max-mtu=1480 mrru=1600
add authentication=mschap2 disabled=no interface=ether2.500 max-mru=1480 max-mtu=1480 mrru=1600
/ip address
add address=<A.B.C.D/25> interface=ether1 network=<A.B.C.128>
/ip dns
set servers=8.8.4.4,8.8.8.8
/ip route
add distance=1 gateway=<A.B.C.254>
/ip service
set telnet disabled=yes
set www disabled=yes
set ssh port=60022
/ppp aaa
set interim-update=1m25s use-radius=yes
/radius
add address=<A.B.C.253> secret=testing123 service=ppp
/routing ospf interface
add interface=ether1 network-type=broadcast
/routing ospf network
add area=backbone network=<A.B.C.128/25>
/snmp
set enabled=yes
/system clock
set time-zone-name=Europe/Moscow
/system identity
set name=pppoe-1100ahx2
/system ntp client
set enabled=yes server-dns-names=europe.pool.ntp.org
/system scheduler
add interval=1d name=Reboot on-event="/system reboot" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive start-date=feb/25/2015 start-time=05:45:00


Загрузка:
Изображение
Активные маршруты OSPF:

Код: Выделить всё

> /routing ospf route print count-only
4084

Загрузка памяти и прочего:

Код: Выделить всё

> /system resource print
             uptime: 7h43m20s
            version: 6.27
         build-time: Feb/11/2015 13:24:13
        free-memory: 1440.2MiB
       total-memory: 1518.7MiB
                cpu: e500v2
          cpu-count: 2
      cpu-frequency: 1066MHz
           cpu-load: 52%
     free-hdd-space: 85.2MiB
    total-hdd-space: 128.0MiB
  architecture-name: powerpc
         board-name: RB1100AHx2
           platform: MikroTik


В общем-то, 500 клиентов без обработки трафика держит вполне сносно. Ещё не пробовал отключать conntrack. Следующий этап проверки - шейпинг по атрибуту RADIUS Mikrotik-Rate-Limit. А вообще, конечно, сюда надо ставить CCR.

Lord3D
Сообщения: 49
Зарегистрирован: 04 окт 2012, 12:39

Re: PPPoE BRAS

Сообщение Lord3D » 10 мар 2015, 21:40

А вот с полисингом по Mikrotik-Rate-Limit с отключенным connection tracking. Количество клиентов, конечно, пришлось уменьшить.
Изображение

Вернуться в «Примеры решений на оборудовании Mikrotik»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость