автоматическая отправка письма по условию

Здесь выкладываем скрипты
kharkov_max
Сообщения: 14
Зарегистрирован: 04 окт 2015, 21:38

Re: автоматическая отправка письма по условию

Сообщение kharkov_max » 01 апр 2016, 09:37

vqd писал(а):скриптом, вешаете в шедуллер и прогоняете скажем каждые 5с.


Для того что бы работало так как Вы подсказываете, необходимо где то хранить текущий список IP и постоянно его обновлять и сравнивать с таблицей (искать новые адреса и слать письмо), что как бы не совсем хорошо, но реально...

Может возможно как то поставить действие именно на добавление в таблицу, или RouterOS этого не позволяет?
vqd
Модератор
Сообщения: 3790
Зарегистрирован: 26 сен 2013, 14:20
Откуда: НСК
Контактная информация:

Re: автоматическая отправка письма по условию

Сообщение vqd » 01 апр 2016, 10:55

Ну храните в массиве, делов то.

Любой подобный мониторинг = скрипт. Просто в случае с микротик авторы не стали за вас что то придумывать
Есть интересная задача и бюджет? http://mikrotik.site
23q
Сообщения: 57
Зарегистрирован: 16 май 2013, 11:21

Re: автоматическая отправка письма по условию

Сообщение 23q » 12 авг 2016, 21:44

kharkov_max писал(а):Прошу прощения что долго не отвечал.

Под таблицей я подразумеваю "Address List" в фаерволе.

vqd писал(а):в чем проблема то? Мониторьте вашу таблицу и в случае изменения выполняйте действие


Вот тут то и вопрос, подскажите как мониторить (скриптом, либо как то можно уже готовым механизмом), и действие выполнить.

предлагаю такой вариант

Код: Выделить всё

/ip firewall filter
add action=add-src-to-address-list address-list=Din chain=forward log=yes log-prefix=Din
/system logging action
add email-to=qwerty@ya.ru name=emailDin target=email
/system logging
add action=emailDin prefix=Din topics=firewall,info
Последний раз редактировалось 23q 12 авг 2016, 21:47, всего редактировалось 1 раз.
23q
Сообщения: 57
Зарегистрирован: 16 май 2013, 11:21

Re: автоматическая отправка письма по условию

Сообщение 23q » 12 авг 2016, 21:46

vqd писал(а):Ну храните в массиве, делов то.

Любой подобный мониторинг = скрипт. Просто в случае с микротик авторы не стали за вас что то придумывать

мне показалось, или ты зазнался? мне твои ответы напомнили ответы "деда" на форуме астериск, которые сводятся к одному - сам дурак(читай мануал).
podarok66
Модератор
Сообщения: 3249
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

Re: автоматическая отправка письма по условию

Сообщение podarok66 » 12 авг 2016, 22:22

23q писал(а):мне показалось, или ты зазнался?

Мне показалось или вы искали повод? Так я и по более расплывчатым случаям решения принимал ничтоже сумняше. Давайте-ка не будем сюда ходить на холивар. А я не буду рубить с плеча тогда...
И это не просьба, а китайское предупреждение.
Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
vqd
Модератор
Сообщения: 3790
Зарегистрирован: 26 сен 2013, 14:20
Откуда: НСК
Контактная информация:

Re: автоматическая отправка письма по условию

Сообщение vqd » 13 авг 2016, 07:30

23q писал(а):мне показалось, или ты зазнался? мне твои ответы напомнили ответы "деда" на форуме астериск, которые сводятся к одному - сам дурак(читай мануал).

Общался с ним, нормальный товарищ. Направление показал, а дальше изучай матчасть и задавай вопросы по существу. Если не дурак то сам дойдешь и под коркой что то останется, а если дурак то хоть носом ткни, бесполезно

Так что да, сам дурак(читай мануал) :-):
Есть интересная задача и бюджет? http://mikrotik.site

Вернуться в «Готовые скрипты Mikrotik»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 3 гостя