Прошу помощи в настройке

Обсуждение общих вопросов, не касающихся настройки оборудования и ОС
zviger
Сообщения: 14
Зарегистрирован: 08 янв 2017, 13:46

Прошу помощи в настройке

Сообщение zviger » 08 янв 2017, 13:51

Добрый день!
Прошу помощи.
Пытаюсь разобраться с закачкой торрентов на NAS WD My Cloud, подключенный к роутеру Mikrotik RB2011UiAS-2HnD-IN. Закачка торрентов происходит через transmission.

При подключении своего старого Keenetic Lite и подсоединению к нему WD My Cloud dct торренты подхватываются моментально через transmission и идёт максимальная отдача и прием, скорость на высоте.
Также при скачивании торрентов через utorrent с компа, закачка идет великолепно.


Теперь подключаем обратно WD My Cloud и комп обратно на Mikrotik, тут начинаются проблемы.
Совсем не закачиваются торренты с трекера hdclub.org, хотя там всегда очень много пиров и на кинетике все просто летает.
Хотя с других трекеров: rutracker, kinozal, закачка идет хорошо.
В это же время, с компа подключенного к микротику все торренты подхватываются моментально через utorrent, со всех трекеров, в том числе и с hdclub.
Помогите, пожалуйста, разобраться и настроить закачку и отдачу торрентов, через transmission.

podarok66
Модератор
Сообщения: 2989
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

Re: Прошу помощи в настройке

Сообщение podarok66 » 08 янв 2017, 16:56

UPnP настроено?
И вообще, чем мы вам поможем без данных? Разве что посочувствуем.Экспорт в студию, пжлст.
Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
zviger
Сообщения: 14
Зарегистрирован: 08 янв 2017, 13:46

Re: Прошу помощи в настройке

Сообщение zviger » 08 янв 2017, 19:06

Интернет работает по L2TP, UPnP не настроено.


/ip firewall filter
add chain=input port=51413 protocol=udp
add chain=input port=51413 protocol=tcp
add chain=input protocol=icmp
add chain=input connection-state=related
add chain=forward connection-state=established
add chain=forward connection-state=related
/ip firewall nat
add action=masquerade chain=srcnat out-interface=Internet src-address=\
192.168.88.0/24
add action=masquerade chain=srcnat disabled=yes out-interface=Internet
add chain=dstnat disabled=yes dst-port=51413 in-interface=Internet protocol=\
tcp to-addresses=192.168.88.241 to-ports=51413
add chain=dstnat disabled=yes dst-port=51413 in-interface=Internet protocol=\
udp to-addresses=192.168.88.241 to-ports=51413
add action=masquerade chain=srcnat out-interface=ether1
podarok66
Модератор
Сообщения: 2989
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

Re: Прошу помощи в настройке

Сообщение podarok66 » 08 янв 2017, 19:58

Надо настроить, торренты его активно используют. Интерфейсы, смотрящие в мир - external, бридж - internal. Все галки включить.
Я у себя еще и порт на торрент-клиенте ставил статический и его пробрасывал из-вне на маршрутизаторе. Тогда просто самолет, весь канал запросто утилизирует.
Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
zviger
Сообщения: 14
Зарегистрирован: 08 янв 2017, 13:46

Re: Прошу помощи в настройке

Сообщение zviger » 08 янв 2017, 20:15

А можно, пожалуйста, поподробнее, как его настроить?
Буду очень благодарен!
zviger
Сообщения: 14
Зарегистрирован: 08 янв 2017, 13:46

Re: Прошу помощи в настройке

Сообщение zviger » 08 янв 2017, 21:35

UPnP настроен. Галочки везде поставил. Картинку приложил с интерфейсами.
Торренты с HD Club все равно не закачиваются((
В Transmission для торрентов с HDclub написано следующее: "Privacy: Private to this tracker -- DHT and PEX disabled"
А для торрентов с кинозала и рутрекера: "Privacy: Public torrent"

Может с этим как-то связано?

В utorrent c компа закачка торрентов с HDclub идет.
zviger
Сообщения: 14
Зарегистрирован: 08 янв 2017, 13:46

Re: Прошу помощи в настройке

Сообщение zviger » 08 янв 2017, 21:43

почему-то картинка не загрузилась.
LAN internal
Internet external
сейчас еще сделал:
ether1 external - (интерфейс WAN порта)
ether4 external - (интерфейс WD MY Cloud)
ether8 external - (интерфейс компа)

Да, кстати в transmission порт 51413 на transmission статический, а как его пробросить из вне на маршрутизаторе? подскажите, пожалуйста.
Аватара пользователя
Dragon_Knight
Модератор
Сообщения: 1310
Зарегистрирован: 26 мар 2012, 18:21
Откуда: МО, Мытищи
Контактная информация:

Re: Прошу помощи в настройке

Сообщение Dragon_Knight » 08 янв 2017, 22:04

У Вас должно быть настроено примерно так, как на картинке, при этом в вашей качалке должна быть включена автоматическая настройка порта, в µTorrent она так и называется UPnP.
Создавать правила вручную не нужно, - это может помешать автоматическому созданию правил.
Изображение

Помощь в настройке оборудования MikroTik, Мытищи, Москва.
Дома: [RouterBOARD CCR1009-8G-1S-1S+] + [RouterBOARD cAP 2n] + [RouterBOARD Groove A-2Hn-32] + [D-Link ANT24-0800];
Работа 1: [RouterBOARD RB493G] + [MikroTik R52H] + [MikroTik CA493] + [D-Link ANT24-0800] + [RouterBOARD SXT G-2HnD];
Работа 2: [RouterBOARD RB2011UiAS-IN];
Резерв: [RouterBOARD RB450G];
podarok66
Модератор
Сообщения: 2989
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

Re: Прошу помощи в настройке

Сообщение podarok66 » 08 янв 2017, 22:38

Dragon_Knight писал(а):Создавать правила вручную не нужно, - это может помешать автоматическому созданию правил.

У меня, как ни странно, динамические правила создаются, но без проброса вручную скорость на отдачу значительно хуже.

Код: Выделить всё

/ip firewall nat
add action=dst-nat chain=dstnat  dst-address=10.201.10.1 \
    dst-port=19336 in-interface=WAN protocol=udp to-addresses=192.168.100.36 to-ports=19336
add action=dst-nat chain=dstnat dst-address=10.201.10.1 \
    dst-port=19336 in-interface=WAN protocol=tcp to-addresses=192.168.100.36 to-ports=19336


10.201.10.1 - IP-адрес, который выдает мне провайдер на мой WAN-интерфейс
192.168.100.36 - внутренний адрес машины с торрент-клиентом
19336 -порт входящих соединений на торрент-клиенте
В принципе у меня счетчики на tcp в 10 раз меньше пакетов показывают, но я уж все повернул для порядка...
Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
zviger
Сообщения: 14
Зарегистрирован: 08 янв 2017, 13:46

Re: Прошу помощи в настройке

Сообщение zviger » 08 янв 2017, 22:57

А мне провайдер не даёт статический ip адрес((

Вернуться в «Общие вопросы»

Кто сейчас на конференции

Сейчас этот форум просматривают: algerka и 2 гостя