Прошу помощи в настройке

Обсуждение общих вопросов, не касающихся настройки оборудования и ОС
DmNuts
Сообщения: 135
Зарегистрирован: 18 май 2016, 18:33
Откуда: Иркутск

Re: Прошу помощи в настройке

Сообщение DmNuts » 09 янв 2017, 04:58

zviger писал(а):А мне провайдер не даёт статический ip адрес((

В данном случае не проблема, в правиле не указывайте dst-address.
zviger
Сообщения: 14
Зарегистрирован: 08 янв 2017, 13:46

Re: Прошу помощи в настройке

Сообщение zviger » 09 янв 2017, 20:35

Торренты с HDClub.org все равно не качаются и не раздаются((

Вот, что получилось:

/ip firewall filter
add chain=input port=51413 protocol=udp
add chain=input port=51413 protocol=tcp
add chain=input protocol=icmp
add chain=input connection-state=related
add chain=forward connection-state=established
add chain=forward connection-state=related
/ip firewall nat
add action=dst-nat chain=dstnat dst-port=51413 in-interface=Internet protocol=\
udp to-addresses=192.168.88.241 to-ports=51413
add action=dst-nat chain=dstnat dst-port=51413 in-interface=Internet protocol=\
tcp to-addresses=192.168.88.241 to-ports=51413
add action=masquerade chain=srcnat out-interface=Internet src-address=\
192.168.88.0/24
add action=masquerade chain=srcnat disabled=yes out-interface=Internet
add chain=dstnat disabled=yes dst-port=51413 in-interface=Internet protocol=tcp \
to-addresses=192.168.88.241 to-ports=51413
add chain=dstnat disabled=yes dst-port=51413 in-interface=Internet protocol=udp \
to-addresses=192.168.88.241 to-ports=51413
add action=masquerade chain=srcnat out-interface=ether1
gmx
Сообщения: 2193
Зарегистрирован: 01 окт 2012, 14:48

Re: Прошу помощи в настройке

Сообщение gmx » 09 янв 2017, 21:26

Да включите уже UpNP и все настроится само собой!

И выключите ВСЕ правила фаерволла.
zviger
Сообщения: 14
Зарегистрирован: 08 янв 2017, 13:46

Re: Прошу помощи в настройке

Сообщение zviger » 10 янв 2017, 06:47

UpNP включил.
А можете, пожалуйста, сказать, что из всего предыдущего моего сообщения нужно отключить?
gmx
Сообщения: 2193
Зарегистрирован: 01 окт 2012, 14:48

Re: Прошу помощи в настройке

Сообщение gmx » 10 янв 2017, 10:54

Выключите все на вкладке IP-Firewall-Filters. Сюда добавляем правила, которые действительно нужны, и работу которых четко понимаете.
zviger
Сообщения: 14
Зарегистрирован: 08 янв 2017, 13:46

Re: Прошу помощи в настройке

Сообщение zviger » 11 янв 2017, 20:25

Убрал все ненужное, проблема не решилась.



/ip firewall filter
add chain=input disabled=yes port=51413 protocol=udp
add chain=input disabled=yes port=51413 protocol=tcp
add chain=input disabled=yes protocol=icmp
add chain=input connection-state=established
add chain=input connection-state=related
add chain=forward connection-state=established
add chain=forward connection-state=related
/ip firewall nat
add action=dst-nat chain=dstnat dst-port=51413 in-interface=Internet protocol=\
udp to-addresses=192.168.88.241 to-ports=51413
add action=dst-nat chain=dstnat dst-port=51413 in-interface=Internet protocol=\
tcp to-addresses=192.168.88.241 to-ports=51413
add action=masquerade chain=srcnat out-interface=Internet src-address=\
192.168.88.0/24
add action=masquerade chain=srcnat out-interface=ether1
zviger
Сообщения: 14
Зарегистрирован: 08 янв 2017, 13:46

Re: Прошу помощи в настройке

Сообщение zviger » 11 янв 2017, 20:31

Во вкладке NAT в добавленных dstnat байты по нулям, картинку почему-то на форум не могу добавить.
gmx
Сообщения: 2193
Зарегистрирован: 01 окт 2012, 14:48

Re: Прошу помощи в настройке

Сообщение gmx » 11 янв 2017, 21:02

Уже не помню, спрашивал или нет?
На устройстве 192.168.88.241 шлюзом микротик???
И на этом устройстве включен свой фаерволл, антивирус или что-то подобное???

Ну и пора бы уже полный кофиг выложить, а не куски.

Ну и даже по куску:
add action=masquerade chain=srcnat out-interface=Internet src-address=\
192.168.88.0/24
add action=masquerade chain=srcnat out-interface=ether1


Так какой у вас интерфейс WAN на самом деле???
zviger
Сообщения: 14
Зарегистрирован: 08 янв 2017, 13:46

Re: Прошу помощи в настройке

Сообщение zviger » 11 янв 2017, 21:44

на устройстве 192.168.88.241 фаерволл и антивирус отсутствует, при подключении через обычный кинетик лайт всё работает, как только подключаю микротик, возникает эта проблема.
в локалку провайдера ether1, а в интернет (l2tp соединение).


Код: Выделить всё

/interface bridge
add mtu=1500 name=LAN
/interface ethernet
set [ find default-name=ether1 ] comment="to WAN"
set [ find default-name=ether2 ] comment="to LAN TV zal"
set [ find default-name=ether3 ] comment="to LAN TV kuhnya"
set [ find default-name=ether4 ] comment="to LAN WD MY Cloud"
set [ find default-name=ether5 ] comment="to LAN TV spalnya"
set [ find default-name=ether6 ] comment="to LAN resiver spalnya"
set [ find default-name=ether7 ] comment="to LAN comp spalnya"
set [ find default-name=ether8 ] comment="to LAN comp zal"
set [ find default-name=ether9 ] comment="to LAN resiver zal"
set [ find default-name=ether10 ] comment="to LAN resiver kuhnya"
/interface l2tp-client
add add-default-route=yes allow=chap connect-to=192.168.168.168 disabled=no \
    name=Internet password=***** user=*****
/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode \
    band=2ghz-b/g/n channel-width=20/40mhz-ht-above country=russia disabled=no \
    distance=indoors frequency-mode=regulatory-domain ht-guard-interval=long \
    hw-protection-mode=rts-cts l2mtu=2290 mode=ap-bridge periodic-calibration=\
    enabled ssid=***** wireless-protocol=802.11 wmm-support=enabled
/ip neighbor discovery
set ether1 comment="to WAN"
set ether2 comment="to LAN TV zal"
set ether3 comment="to LAN TV kuhnya"
set ether4 comment="to LAN WD MY Cloud"
set ether5 comment="to LAN TV spalnya"
set ether6 comment="to LAN resiver spalnya"
set ether7 comment="to LAN comp spalnya"
set ether8 comment="to LAN comp zal"
set ether9 comment="to LAN resiver zal"
set ether10 comment="to LAN resiver kuhnya"
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=\
    dynamic-keys wpa2-pre-shared-key=*****
/ip pool
add name=dhcp ranges=192.168.88.2-192.168.88.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=LAN lease-time=3d name=dhcp1
/port
set 0 name=serial0
/interface bridge port
add bridge=LAN interface=wlan1
add bridge=LAN interface=ether2
add bridge=LAN interface=ether3
add bridge=LAN interface=ether4
add bridge=LAN interface=ether5
add bridge=LAN interface=ether6
add bridge=LAN interface=ether7
add bridge=LAN interface=ether8
add bridge=LAN interface=ether9
add bridge=LAN interface=ether10
/ip address
add address=192.168.88.1/24 interface=ether2 network=192.168.88.0
/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
    interface=ether1
/ip dhcp-server lease
add address=192.168.88.241 mac-address=*********** server=dhcp1
/ip dhcp-server network
add address=192.168.88.0/24 dns-server=192.168.88.1 gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip firewall filter
add chain=input disabled=yes port=51413 protocol=udp
add chain=input disabled=yes port=51413 protocol=tcp
add chain=input disabled=yes protocol=icmp
add chain=input connection-state=established
add chain=input connection-state=related
add chain=forward connection-state=established
add chain=forward connection-state=related
/ip firewall nat
add action=dst-nat chain=dstnat dst-port=51413 in-interface=Internet protocol=\
    udp to-addresses=192.168.88.241 to-ports=51413
add action=dst-nat chain=dstnat dst-port=51413 in-interface=Internet protocol=\
    tcp to-addresses=192.168.88.241 to-ports=51413
add action=masquerade chain=srcnat out-interface=Internet src-address=\
    192.168.88.0/24
add action=masquerade chain=srcnat out-interface=ether1
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=LAN type=internal
add interface=Internet type=external
add disabled=yes interface=ether1 type=external
add disabled=yes interface=ether4 type=external
add disabled=yes interface=ether8 type=external
/lcd interface pages
set 0 interfaces=\
    sfp1,ether1,ether2,ether3,ether4,ether5,ether6,ether7,ether8,ether9,ether10
/system clock
set time-zone-name=Europe/Moscow
DmNuts
Сообщения: 135
Зарегистрирован: 18 май 2016, 18:33
Откуда: Иркутск

Re: Прошу помощи в настройке

Сообщение DmNuts » 12 янв 2017, 10:04

Вот так будет правильно:

Код: Выделить всё

/ip address
add address=192.168.88.1/24 interface=LAN network=192.168.88.0
Т.к. ethernet интерфейсы в бридже, то и адрес надо на бридж назначать.
"/ip firewall nat add action=masquerade chain=srcnat out-interface=ether1" - это может понадобиться только в том случае, если в серой сети провайдера есть какие-то ресурсы. Иначе убрать лишнее правило. Вероятно, там есть ретрекеры rutracker и kinozal, поэтому с них WD MY Cloud может качать при ваших настройках.
Покажите ещё вывод /ip route print.

Вернуться в «Общие вопросы»

Кто сейчас на конференции

Сейчас этот форум просматривают: Bing [Bot] и 1 гость