Подключение по L2TP к провайдеру (Пчелайн)

Обсуждение ОС и пр.
Аватара пользователя
prozorliviy
Сообщения: 19
Зарегистрирован: 26 ноя 2013, 18:10

Re: Подключение по L2TP к провайдеру (Пчелайн)

Сообщение prozorliviy » 28 ноя 2013, 00:08

Сам дивлюсь, что так долго решали вопрос всем миром, главное что разрешили, буду потихоньку осваивать эти загадки по использованию и настройке микротика. Спасибо!!!

vdv-hm
Сообщения: 6
Зарегистрирован: 26 ноя 2013, 16:20

Re: Подключение по L2TP к провайдеру (Пчелайн)

Сообщение vdv-hm » 28 ноя 2013, 11:42

Добрый день!

Интересная получилась тема, к счастью я этот этап уже прошел, теперь этап 2: подключения SIP-телефона в сети Билайн.

Исходные данные:
Есть SIP-телефон GIGASET C470 IP, настроен на SIP шлюз Билайн, домен: sip.beeline.ru, прокси: msk.sip.beeline.ru и на еще один SIP-шлюз в Интернете.
Проблема в том, что при настройке L2TP появляется доступ к SIP-шлюзу в Интернете, но пропадает доступ к SIP-шлюзу Билайн и на оборот - при отключении LT2P появляется к к SIP-шлюзу Билайн, но пропадает к SIP-шлюзу в Интернете.
Задача состоит в том, чтобы доступ был к обоим SIP-шлюзам.

Видимо нужно правильно прописывать маршрут, но у меня пока ничего не получилось.
Прошу помощи.

Конфигурация Mikrotik:
 

Код: Выделить всё

[***@MikroTik] > export
# nov/27/2013 23:18:11 by RouterOS 6.6
# software id = U6DS-GVB1
#
/interface bridge
add l2mtu=1598 name=bridge1
/interface ethernet
set [ find default-name=ether3 ] master-port=ether2
set [ find default-name=ether4 ] master-port=ether2
set [ find default-name=ether5 ] master-port=ether2
set [ find default-name=ether7 ] master-port=ether6
set [ find default-name=ether8 ] master-port=ether6
/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode \
    basic-rates-b=11Mbps country=russia disabled=no
frequency-mode=superchannel \
    ht-rxchains=0,1 ht-txchains=0,1 l2mtu=2290 mode=ap-bridge \
    periodic-calibration=enabled periodic-calibration-interval=10 ssid=Bee \
    supported-rates-b=11Mbps tx-power=20 tx-power-mode=all-rates-fixed \
    wds-default-bridge=bridge1 wds-mode=dynamic wireless-protocol=802.11 \
    wmm-support=enabled
/interface wireless nstreme
set wlan1 enable-polling=no
/interface wireless channels
add band=2ghz-b/g/n disabled=yes frequency=2412 list=1 name=ch1 width=20
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" \
    group-ciphers=tkip,aes-ccm mode=dynamic-keys unicast-ciphers=tkip,aes-ccm \
    wpa-pre-shared-key=******** wpa2-pre-shared-key=********
/ip pool
add name=dhcp_pool1 ranges=192.168.0.2-192.168.0.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=bridge1 name=dhcp1
/port
set 0 name=serial0
/ppp profile
add change-tcp-mss=yes name=Beeline remote-address=127.0.2.1
use-compression=no \
    use-encryption=no use-vj-compression=no
/interface l2tp-client
add add-default-route=yes connect-to=78.107.1.14 disabled=no name=l2tp-out1 \
    password=**** profile=Beeline user=****
/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether6
add bridge=bridge1 interface=wlan1
/ip address
add address=192.168.0.1/24 interface=wlan1 network=192.168.0.0
/ip dhcp-client
add default-route-distance=2 dhcp-options=hostname,clientid disabled=no \
    interface=ether1
add default-route-distance=0 dhcp-options=hostname,clientid
/ip dhcp-server network
add address=192.168.0.0/24 dns-server=192.168.0.1 gateway=192.168.0.1
/ip dns
set allow-remote-requests=yes
/ip firewall mangle
add action=change-mss chain=forward in-interface=l2tp-out1 new-mss=1420 \
    protocol=tcp tcp-flags=syn tcp-mss=1391-65535
/ip firewall nat
add action=masquerade chain=srcnat out-interface=l2tp-out1 src-address=\
    192.168.0.0/24
/ip route
add comment=VOIP disabled=yes distance=1 dst-address=10.25.0.0/24 gateway=\
    10.60.128.1
add comment="vpn servers subnet" distance=1 dst-address=78.107.1.0/24 gateway=\
    10.60.128.1
add comment="vpn servers subnet" distance=1 dst-address=85.21.0.0/24 gateway=\
    10.60.128.1
add comment=VOIP distance=1 dst-address=195.239.253.0/24 gateway=10.60.128.1
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=bridge1 type=internal
add interface=l2tp-out1 type=external
/lcd interface
set sfp1 interface=sfp1
set ether1 interface=ether1
set ether2 interface=ether2
set ether3 interface=ether3
set ether4 interface=ether4
set ether5 interface=ether5
set ether6 interface=ether6
set ether7 interface=ether7
set ether8 interface=ether8
set ether9 interface=ether9
set ether10 interface=ether10
set wlan1 interface=wlan1
/system clock
set time-zone-name=Europe/Moscow
/system ntp client
set enabled=yes mode=unicast primary-ntp=193.124.4.177 secondary-ntp=85.21.78.8
/system scheduler
add interval=1s name=l2tp_soft_refresh on-event=\
    "/system script run l2tp_soft_refresh"
policy=reboot,read,write,policy,test \
    start-date=jan/02/1970 start-time=00:00:00
add interval=1h name=l2tp_refresh on-event="/system script run l2tp_refresh" \
    policy=reboot,read,write,policy,test start-date=jan/02/1970 start-time=\
    04:30:00
/system script
add name=l2tp_soft_refresh policy=ftp,read,write,winbox source=":local
interface\
    \_\"l2tp-out1\"\r\
    \n:local vpnserver \"tp.internet.beeline.ru\"\r\
    \n#:log debug message=\"Soft resolv script run\"\r\
    \n:if ([/interface l2tp-client get \$interface running] = false) do={\r\
    \n :log info message=\"VPN down. Refreshing\"\r\
    \n /ip dns cache flush\r\
    \n :local \"current-ip\" [:resolve \$vpnserver]\r\
    \n :local \"old-ip\" [/interface l2tp-client get [/interface
l2tp-client fin\
    d name=\"\$interface\"] connect-to]\r\
    \n :if (\$\"current-ip\" != \$\"old-ip\") do= {\r\
    \n :log info \"VPN Server changed IP address from \$\"old-ip\" to
\$\"curren\
    t-ip\"\"\r\
    \n /interface l2tp-client set [/interface l2tp-client find
name=\"\$interfac\
    e\"] connect-to=\$\"current-ip\"\r\
    \n }\r\
    \n}"
add name=l2tp_refresh policy=ftp,read,write,winbox source=":local
interface \"l2\
    tp-out1\"\r\
    \n:local vpnserver \"tp.internet.beeline.ru\"\r\
    \n:log debug message=\"Hard resolv script run\"\r\
    \n#:if ([/interface l2tp-client get \$interface running] = false) do={\r\
    \n /ip dns cache flush\r\
    \n :local \"current-ip\" [:resolve \$vpnserver]\r\
    \n :local \"old-ip\" [/interface l2tp-client get [/interface
l2tp-client fin\
    d name=\"\$interface\"] connect-to]\r\
    \n :if (\$\"current-ip\" != \$\"old-ip\") do= {\r\
    \n :log info \"VPN Server changed IP address from \$\"old-ip\" to
\$\"curren\
    t-ip\"\"\r\
    \n /interface l2tp-client set [/interface l2tp-client find
name=\"\$interfac\
    e\"] connect-to=\$\"current-ip\"\r\
    \n }\r\
    \n#}"
Аватара пользователя
simpl3x
Модератор
Сообщения: 1884
Зарегистрирован: 19 апр 2012, 14:03

Re: Подключение по L2TP к провайдеру (Пчелайн)

Сообщение simpl3x » 28 ноя 2013, 15:19

/ip route
add comment=VOIP disabled=yes distance=1 dst-address=10.25.0.0/24 gateway=\
10.60.128.1
add comment="vpn servers subnet" distance=1 dst-address=78.107.1.0/24 gateway=\
10.60.128.1
add comment="vpn servers subnet" distance=1 dst-address=85.21.0.0/24 gateway=\
10.60.128.1
add comment=VOIP distance=1 dst-address=195.239.253.0/24 gateway=10.60.128.1


10.60.128.1 - это что?

в момент подключения сделайте
/ip address print
/ip route print
vdv-hm
Сообщения: 6
Зарегистрирован: 26 ноя 2013, 16:20

Re: Подключение по L2TP к провайдеру (Пчелайн)

Сообщение vdv-hm » 28 ноя 2013, 16:20

10.60.128.1 - gateway Билайна

Вечером сделаю:
/ip address print
/ip route print
Аватара пользователя
simpl3x
Модератор
Сообщения: 1884
Зарегистрирован: 19 апр 2012, 14:03

Re: Подключение по L2TP к провайдеру (Пчелайн)

Сообщение simpl3x » 28 ноя 2013, 17:55

заодно попробуйте как то так сделать:

Код: Выделить всё

ip route add dst-address=1.1.1.1 gateway=12.12.12.12 routing-mark=voip_over_direct
ip route add dst-address=2.2.2.2 gateway=l2tp-out1 routing-mark=voip_over_l2tp
ip route rule add dst-address=1.1.1.1 action=lookup table=voip_over_direct
ip route rule add dst-address=2.2.2.2 action=lookup table=voip_over_l2tp

где 1.1.1.1 адреса билайновских voip, 12.12.12.12 соответственно шлюз
2.2.2.2 другие воип сервера, l2tp-out1 - интерфейс вашего подключения
в теории должно работать.
vdv-hm
Сообщения: 6
Зарегистрирован: 26 ноя 2013, 16:20

Re: Подключение по L2TP к провайдеру (Пчелайн)

Сообщение vdv-hm » 28 ноя 2013, 18:57

Код: Выделить всё

>[b] /ip address prin[/b]t
Flags: X - disabled, I - invalid, D - dynamic
 #   ADDRESS            NETWORK         INTERFACE                                                                                                                                                                                                         
 0   192.168.0.1/24     192.168.0.0     wlan1                                                                                                                                                                                                             
 1 D 10.60.133.143/20   10.60.128.0     ether1                                                                                                                                                                                                           
 2 D 95.25.136.162/32   127.0.2.1       l2tp-out1   

[b] > /ip route print[/b]
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADS  0.0.0.0/0                          127.0.2.1                 1
 1  DS  0.0.0.0/0                          10.60.128.1               2
 2 X S  ;;; VOIP
        10.25.0.0/24                       10.60.128.1               1
 3 ADC  10.60.128.0/20     10.60.133.143   ether1                    0
 4 A S  ;;; vpn servers subnet
        78.107.1.0/24                      10.60.128.1               1
 5 A S  ;;; vpn servers subnet
        85.21.0.0/24                       10.60.128.1               1
 6 ADS  85.21.78.93/32                     10.60.128.1               2
 7 ADS  85.21.88.130/32                    10.60.128.1               2
 8 ADC  127.0.2.1/32       95.25.136.162   l2tp-out1                 0
 9 ADC  192.168.0.0/24     192.168.0.1     bridge1                   0
10 ADS  194.67.1.115/32                    10.60.128.1               2
11 ADS  195.14.50.16/32                    10.60.128.1               2
12 ADS  195.14.50.21/32                    10.60.128.1               2
13 ADS  195.14.50.26/32                    10.60.128.1               2
14 ADS  195.14.50.93/32                    10.60.128.1               2
15 A S  ;;; VOIP
        195.239.253.0/24                   10.60.128.1               1


Сейчас попробую как Вы предложили
Аватара пользователя
simpl3x
Модератор
Сообщения: 1884
Зарегистрирован: 19 апр 2012, 14:03

Re: Подключение по L2TP к провайдеру (Пчелайн)

Сообщение simpl3x » 28 ноя 2013, 19:30

127.0.2.1 - это прикол такой? )))
podarok66
Модератор
Сообщения: 2980
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

Re: Подключение по L2TP к провайдеру (Пчелайн)

Сообщение podarok66 » 28 ноя 2013, 19:50

Адреса класса A с 127.0.0.0 по 127.255.255.255 не могут использоваться, потому что являются зарезервироваными для loopback и диагностики.
Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
vdv-hm
Сообщения: 6
Зарегистрирован: 26 ноя 2013, 16:20

Re: Подключение по L2TP к провайдеру (Пчелайн)

Сообщение vdv-hm » 28 ноя 2013, 19:51

127.0.2.1 - это прикол такой? )))
- возможно, взял из документа:
[url]http://old.minirouter.ru/wp-content/uploads/2010/06/Инструкция-по-конфигурированию-Mikrotik-RouterOS-для-работы-в-сети-интернет-провайдера-Корбина-Телеком-Билайн-07.07.2011.pdf[/url]

Сделал, но результат неизменен:

Код: Выделить всё

[b]> ip route print[/b]
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 A S  10.25.0.50/32                      10.60.128.1               1
 1 A S  195.239.253.100/32                 10.60.128.1               1
 2 A S  77.72.169.129/32                   l2tp-out1                 1
 3 A S  77.72.169.131/32                   l2tp-out1                 1
 4 A S  77.72.174.18/32                    l2tp-out1                 1
 5 ADS  0.0.0.0/0                          127.0.2.1                 1
 6  DS  0.0.0.0/0                          10.60.128.1               2
 7 X S  ;;; VOIP
        10.25.0.0/24                       10.60.128.1               1
 8 ADC  10.60.128.0/20     10.60.133.143   ether1                    0
 9 A S  ;;; vpn servers subnet
        78.107.1.0/24                      10.60.128.1               1
10 A S  ;;; vpn servers subnet
        85.21.0.0/24                       10.60.128.1               1
11 ADS  85.21.78.93/32                     10.60.128.1               2
12 ADS  85.21.88.130/32                    10.60.128.1               2
13 ADC  127.0.2.1/32       95.24.168.175   l2tp-out1                 0
14 ADC  192.168.0.0/24     192.168.0.1     bridge1                   0
15 ADS  194.67.1.115/32                    10.60.128.1               2
16 ADS  195.14.50.16/32                    10.60.128.1               2
17 ADS  195.14.50.21/32                    10.60.128.1               2
18 ADS  195.14.50.26/32                    10.60.128.1               2
19 ADS  195.14.50.93/32                    10.60.128.1               2
20 X S  ;;; VOIP
        195.239.253.0/24                   10.60.128.1               1





[b]> ip address print [/b]
Flags: X - disabled, I - invalid, D - dynamic
 #   ADDRESS            NETWORK         INTERFACE                                                                                                                                                                                                         
 0   192.168.0.1/24     192.168.0.0     wlan1                                                                                                                                                                                                             
 1 D 10.60.133.143/20   10.60.128.0     ether1                                                                                                                                                                                                           
 2 D 95.24.168.175/32   127.0.2.1       l2tp-out1   
Аватара пользователя
simpl3x
Модератор
Сообщения: 1884
Зарегистрирован: 19 апр 2012, 14:03

Re: Подключение по L2TP к провайдеру (Пчелайн)

Сообщение simpl3x » 28 ноя 2013, 21:54

а попробуйте вместо l2tp-out1 написать ваш 127.0.2.1

Вернуться в «MikroTik RouterOS»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 2 гостя